WordPress 2.0.9 and 2.1.1

The latest updates to WordPress were released while I was in London[1].

For those, like me, who haven’t upgraded to WordPress 2.1 for reasons of plugin compatibility, laziness, lack of time or whatever, there is a security update you need. And if you’re wondering how we’ve gone from 2.0.7 to 2.0.9, well, it seems there was a bit of a tuit issue at WordPress. Version 2.0.8 was finished, and indeed was available from the Release Archive, but no actual announcement was made. Then along came another security issue, so a new version was needed. Anyway, if you’re running WordPress 2.0.x, you need to get 2.0.9 to avoid elephants falling on your head.

The developers have committed to continue providing security updates to 2.0.x until 2010, but they really want people to upgrade to 2.1, as that’s where the new features will be appearing. Talking of which, there are some updates for 2.1, now available as version 2.1.1.

Full details in the WordPress Development Blog, which helpfully lists the files that have changed since the last releases, so provided you were up to date, you can do a quick update by just replacing those files.

Version 2.1.1 is available from the main Download page, and 2.0.9 is in the Release Archive. Make sure you get 2.0.9 and not the Beta or RC versions!

[1] Mutter, conspiracy, mutter.