WordPress security warning

I mentioned a while ago that WordPress 2.2 has been released, and that upgrading from 2.1.x was a painless procedure.

Well, if you’re still running 2.1.3 or earlier, can I suggest that you stop reading this, and upgrade to 2.2 now. There is a security flaw in 2.1.3 which is fixed in 2.2. Reports on the WordPress support forums suggest that there is an exploit in the wild, which is affecting WordPress 2.1.3 and earlier.

There will be no further releases in the 2.1.x series – your upgrade path is to 2.2.

For anyone still using WordPress 2.0.x, this does not affect you – version 2.0.10 is still current, and there will be security and bug fixes released as required. But you won’t get any new features unless you upgrade to 2.2.